Xero validation error updating Supplier
Error:
Error updating Supplier "x". The contact number number must be unique across all contacts" (where "x" is your supplier code)
Cause:
The issue is caused by another supplier with the same Contact Code in Xero, typically where the duplicate contact has been either archived or merged in Xero.
You will need to restore the version of the contact in Xero. For detailed information on restoring/merging contacts in Xero please refer to Xero Central support.